Reply to topic  [ 13 posts ] 
Polo tdi power loss 
Author Message
Enlisted

Joined: Tue Jun 24, 2008 8:03 am
Posts: 32
Car Make: vw
Car Model: polo tdi
Hi guys

I have a 2007 polo tdi (96kw) ok so a few weeks ago my turbo packed up,after the turbo change was done along with cambelt & waterpump the car is not boosting correctly.My main problem is that if i drive the car hard (robot to robot ) the car has no power at all,if i stop switch off start up again its fine.Boost seems to be coming in at 2000+RPM,any help we be great.


Thank's


Tue Mar 15, 2011 9:44 pm
Profile
VWCSA Member
User avatar

Joined: Thu Mar 08, 2007 10:36 am
Posts: 19383
Location: Lenasia
Car Model: boat
Membership No: 1133
Who did the repair?

_________________
The disreputer

Image


Tue Mar 15, 2011 9:45 pm
Profile WWW
Captain

Joined: Thu Sep 18, 2008 11:57 am
Posts: 2302
Location: Gangsta's Paradi$e - GP
well the turbo's generally come inn at 2000RPM on the tdi.....

check it up and see if u can pick up any faults on it

_________________
1.Golf 6 Ed. 35 - 2013 ( Tornado Red )
2.2004 Golf 1 Baby 1.4i +VAT :evil: 76.3 WHP@K.A.R
3. Polo 2008(9n3) Ex:-(
4.Golf 1 ( 2 door ) branch,exhaust,domingo's,leather seats,electric windows, 2.0L 16v ( sold ) :cry: Ex.
5.Golf 2 Exec. 20L 16v full house ( RIP ) :bang: Ex
6.Jetta 2 1.8 16v full house ( sold ) Ex
Image


Tue Mar 15, 2011 9:48 pm
Profile
Enlisted

Joined: Tue Jun 24, 2008 8:03 am
Posts: 32
Car Make: vw
Car Model: polo tdi
B K motors -

In 6th gear at 80km-90km it struggles to get to 100km


Tue Mar 15, 2011 10:06 pm
Profile
VWCSA Member
User avatar

Joined: Thu Mar 08, 2007 10:36 am
Posts: 19383
Location: Lenasia
Car Model: boat
Membership No: 1133
Take it back there

_________________
The disreputer

Image


Tue Mar 15, 2011 10:27 pm
Profile WWW
Moderator
Technical Advisor
User avatar

Joined: Tue Jul 18, 2006 6:51 pm
Posts: 3850
Location: jhb
Membership No: 388
New or recon unit?

Take it back and let them check the errors and take it from there.
If it is recon unit they have 10-1 not adjusted waste gate/vains correct.

_________________
G60 16V GOLF

WHAT WE LEAVE BEHIND IS NOT AS IMPORTANT AS HOW WE LIVED.

IT IS NOT UNSAFE IT IS OLD SCHOOL!!!!!!!!!

ALDO IS THE MAN WITH A GUN.
THATS HOW WE ROLL [SAINT-J]
GTS KNOWS HOW TO MAKE A STICKER.


Wed Mar 16, 2011 6:51 am
Profile
Enlisted

Joined: Tue Jun 24, 2008 8:03 am
Posts: 32
Car Make: vw
Car Model: polo tdi
I've been back there almost everyday it's a new turbo the mechanic said it could be a faulty boost controller but he does not have a new one to test with, my point is only after the turbo change did this happen


Wed Mar 16, 2011 9:20 am
Profile
Lieutenant-Colonel
User avatar

Joined: Mon Sep 04, 2006 10:18 am
Posts: 4084
Location: Port Elizabeth
Car Make: Volkswagen
Car Model: 2005 Polo 1.9 TDi Sportline
citigolf1.4i wrote:
B K motors -

In 6th gear at 80km-90km it struggles to get to 100km

I wouldn't load like that either.

_________________
Matteo
2005 Polo 1.9TDi Sportline - Sooty
Image


Wed Mar 16, 2011 9:33 am
Profile
Cadet
User avatar

Joined: Thu Dec 04, 2008 1:55 pm
Posts: 868
Location: Roodepoort
citigolf1.4i wrote:
the mechanic said it could be a faulty boost controller


Get a new mechanic

_________________
'05 Audi A4 2.0TDI Avant
'00 Audi A3 1.8T


Wed Mar 16, 2011 10:06 am
Profile WWW
VWCSA Member
User avatar

Joined: Mon Jan 07, 2008 3:50 pm
Posts: 10153
Location: Roodepoort
Car Make: Audi
Car Model: 8J TT 2.0TFSI
Membership No: 1327
Get the car to a vw dealership to get it checked. Take it from there

_________________
Darryn Van Rooyen
Current: 2009 Audi TT 2.0TFSI S-Tronic
Mods: Revo2 and 76mm DP
Current: 2008 Honda CBX250 Twister
Previous:
2011 Amarok BiTDI D/C Highline 4Motion
130.3WHP and 297Nm @ KAR 25/01/2014
08 RS MKV GTI DSG
231WHP and 395NM @ KAR 03/03/2013
09 ZG Ibiza Cupra TDI-Best car I ever owned!
167WHP and 419nm @ KAR
06 CW Sportline
121WHP and 310NM @ KAR
01 Citi 1.4i
01 Yamaha YZ125
99 Toyota Tazz
94 Fox 1.8 Sport


Wed Mar 16, 2011 10:17 am
Profile
Major
User avatar

Joined: Sat Oct 23, 2010 9:47 am
Posts: 3897
Location: Fochville
Car Make: VW
Car Model: Jetta 4 1.9 Tdi, Isuzu2.5DKBLe
Check all the vacuum pipes for leaks and if connected properly. Also check if maf sensor is plugged in properly. Don't take everything for granted, its your car so check everything out yourself after a service. Did they adjust the timing after changing the cambelt?

_________________
Robin
Current rides: 02' Jetta 4 1.9 Tdi, 99' Isuzu KB 250 Dle(Faithfull aka slowmo) 96' Pajero 2.8Tdi LWB
Ex rides: 82' jetta 1.5 Gls(sold), 88' jetta Clx(sold with tears in my eyes)

Rather buy a good quality part that will last then buying a cheap part that won't last.


VCDS user with HEX-USB+CAN cable(Rosstech)

robinwisse@gmail.com


Wed Mar 16, 2011 10:27 am
Profile
Cadet
User avatar

Joined: Wed Apr 15, 2009 2:06 pm
Posts: 682
Location: Johannesburg
Car Make: Kia
Car Model: Rio Hatch
Take it to Trevor. 083 309 5033.

_________________
Justin Roberts
Membership Number: 1562

Current Ride:
2013 Renault Clio 4

Previous Rides:
2012 Kia Rio Hatch

2006 Volkswagen Polo 1.9TDI Sportline

Image


Wed Mar 16, 2011 11:32 am
Profile
Enlisted

Joined: Tue Jun 24, 2008 8:03 am
Posts: 32
Car Make: vw
Car Model: polo tdi
Thanks guys for all the help gonna start checking everything then go to vw


Wed Mar 16, 2011 4:25 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 13 posts ] 
View new posts | View your posts

Who is online

Users browsing this forum: Bing [Bot], Force Fed, Google [Bot], shlumz and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software for PTF.